Muff's website forum

Пожалуйста, войдите или зарегистрируйтесь.

Расширенный поиск  

Новости:

SMF - Just Installed!

Автор Тема: Nagios + Nconf  (Прочитано 28732 раз)

muff

  • Administrator
  • Долгожитель
  • ***
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 283
    • Просмотр профиля
    • IT, Network, Beer!
Re: Nagios + Nconf
« Ответ #15 : Сентября 01, 2011, 01:53:57 pm »

Какие права на каталог /usr/local/etc/nagios/global ?
Записан
Если нет ответа, то давайте подумаем...

riko

  • Пионер
  • *
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 3
    • Просмотр профиля
Re: Nagios + Nconf
« Ответ #16 : Сентября 01, 2011, 06:40:19 pm »

chmod 766
chown nagios:www
Записан

muff

  • Administrator
  • Долгожитель
  • ***
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 283
    • Просмотр профиля
    • IT, Network, Beer!
Re: Nagios + Nconf
« Ответ #17 : Сентября 01, 2011, 07:17:46 pm »

Владельцем должен быть пользователь, от имени которого работает веб-сервер. В данном случае - www.
Записан
Если нет ответа, то давайте подумаем...

riko

  • Пионер
  • *
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 3
    • Просмотр профиля
Re: Nagios + Nconf
« Ответ #18 : Сентября 02, 2011, 02:42:53 pm »

у меня в каталогах globa и Default_collector  было пусто.. так я сделал вот так

www/nconf/output>tar -xf NagiosConfig.tgz

cp -iprv /usr/local/www/nconf/output/Default_collector/ /usr/local/etc/nagios/Default_collector/

cp -iprv /usr/local/www/nconf/output/global/ /usr/local/etc/nagios/global/

и нагиос стартанул.. теперь столкнулся с следующей ошибкой

http://localhost/nagios/
It appears as though you do not have permission to view information for any of the services you requested...
If you believe this is an error, check the HTTP server authentication requirements for accessing this CGI
and check the authorization options in your CGI configuration file.
Записан

muff

  • Administrator
  • Долгожитель
  • ***
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 283
    • Просмотр профиля
    • IT, Network, Beer!
Re: Nagios + Nconf
« Ответ #19 : Сентября 02, 2011, 02:56:19 pm »

В том то и дело, что скрипт deploy_local.sh должен это делать в автоматическом режиме.

На счет ошибки - четко описано, что недостаточно прав. Проверьте права на файлы и каталоги.Также ознакомьтесь с пунктом 3 примечаний.
Записан
Если нет ответа, то давайте подумаем...

Miraf

  • Пионер
  • *
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 5
    • Просмотр профиля
Re: Nagios + Nconf
« Ответ #20 : Июля 24, 2012, 07:52:23 pm »

кто будет так любезен и покажет как в httpd-vhosts.conf правильно прописать nagios ?
Записан

muff

  • Administrator
  • Долгожитель
  • ***
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 283
    • Просмотр профиля
    • IT, Network, Beer!
Re: Nagios + Nconf
« Ответ #21 : Июля 24, 2012, 08:55:48 pm »

Как виртуалхост он не прописывается, необходимо прописывать его как алиас:

Alias /nagios/ "/usr/local/www/nagios/"
<Directory /usr/local/www/nagios/>
        Order deny,allow
        Allow from all
        AuthName "Nagios Access"
        AuthType Basic
        AuthUserFile /usr/local/etc/nagios/.htpasswd-nagios
        Require valid-user
</Directory>
<Directory /usr/local/www/nagios/cgi-bin/>
        Options ExecCGI
        AuthName "Nagios Access"
        AuthType Basic
        AuthUserFile /usr/local/etc/nagios/.htpasswd-nagios
        Require valid-user
</Directory>
Записан
Если нет ответа, то давайте подумаем...

Sargas

  • Пионер
  • *
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 6
    • Просмотр профиля
Re: Nagios + Nconf
« Ответ #22 : Июля 26, 2012, 09:38:11 pm »

<VirtualHost ip:80>
        ServerName nagios.example.com
        ErrorLog /home/LOGS/ERRORS/311072786.apache2
        <IfModule mod_log_config.c>
                CustomLog /home/LOGS/ACCESS/311072786.apache2 combined
        </IfModule>
        ServerAlias  www.nagios.example.com

        DocumentRoot /home/nagios/nagios.example.com
        <IfModule mod_alias.c>
                ScriptAlias /cgi-bin/ /home/nagios/nagios.example.com/cgi-bin/
        </IfModule>
        <IfModule mod_php4.c>
                php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -f nagios@example.com"
        </IfModule>
        <IfModule mod_php5.c>
                php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -f nagios@example.com"
        </IfModule>
</VirtualHost>
Записан

Miraf

  • Пионер
  • *
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 5
    • Просмотр профиля
Re: Nagios + Nconf
« Ответ #23 : Августа 11, 2012, 12:46:11 pm »

Гугл помог
<VirtualHost *:80>

ServerAdmin test@xxxx
DocumentRoot "/usr/local/www/nagios/"
ServerName nagios.xx.xx.ua

ScriptAlias /cgi-bin/  "/usr/local/www/nagios/cgi-bin/"
ServerAlias www.nagios.xx.xx.ua

Alias /nagios/ "/usr/local/www/nagios/"

<Directory /usr/local/www/nagios/>
        Order deny,allow
       Allow from all
        AuthName "Nagios Access"
        AuthType Basic
        AuthUserFile /usr/local/etc/nagios/.htpasswd.nagios
        Require valid-user
</Directory>

<Directory /usr/local/www/nagios/cgi-bin/>
        Options ExecCGI
        AuthName "Nagios Access"
        AuthType Basic
        AuthUserFile /usr/local/etc/nagios/.htpasswd.nagios
        Require valid-user
</Directory>

</VirtualHost>

Вот еще такой вопрос.
При падении хоста, выставив его в  acknowledgement необходимо отдельно делать acknowledgement сервисам.
Возможно ли при подтверждении(acknowledgement) для хоста, чтоб автоматически применялось и к сервисам?
« Последнее редактирование: Августа 11, 2012, 12:54:09 pm от Miraf »
Записан

muff

  • Administrator
  • Долгожитель
  • ***
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 283
    • Просмотр профиля
    • IT, Network, Beer!
Re: Nagios + Nconf
« Ответ #24 : Августа 13, 2012, 12:02:45 pm »

Выбираем хост, для которого необходимо отключить уведомления и в "Host Commands" (справа) выбираем опцию "Disable notifications for all services on this host". В окне подтверждения есть возможность поставить чекбокс "Disable For Host Too".
Записан
Если нет ответа, то давайте подумаем...
 

Страница сгенерирована за 0.067 секунд. Запросов: 33.