Muff's website forum

Пожалуйста, войдите или зарегистрируйтесь.

Расширенный поиск  

Новости:

SMF - Just Installed!

Автор Тема: не ставится Nconf  (Прочитано 13137 раз)

lexx

  • Пионер
  • *
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 4
    • Просмотр профиля
не ставится Nconf
« : Ноября 29, 2011, 09:05:36 pm »

Привет!
пишет: Perl 5.6 (or higher) ->    FAILED
хотя перл 5.12
# pkg_info | grep perl
p5-DBI-1.616_1      The perl5 Database Interface.  Required for DBD::* modules
perl-5.12.4_3       Practical Extraction and Report Language
Кто подскажет как победить?
Записан

Sargas

  • Пионер
  • *
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 6
    • Просмотр профиля
Re: не ставится Nconf
« Ответ #1 : Ноября 29, 2011, 09:44:45 pm »

Ну все правильно пишет. У вас старая версия перла. Обновите Perl
Записан

lexx

  • Пионер
  • *
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 4
    • Просмотр профиля
Re: не ставится Nconf
« Ответ #2 : Ноября 29, 2011, 09:54:50 pm »

Странно. я всегда думал что 12 больше чем  6 ))
А если серьезно, то не понял ответа.

В требованиях написано 5.6 или выше, у меня установлен 5.12 - почему не ставиться nconf?
« Последнее редактирование: Ноября 29, 2011, 10:00:21 pm от lexx »
Записан

Sargas

  • Пионер
  • *
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 6
    • Просмотр профиля
Re: не ставится Nconf
« Ответ #3 : Ноября 29, 2011, 10:30:26 pm »

Потому что Perl 5.12 старее чем Perl 5.6

Нумерация идет 5.12, 5.13, 5.2, 5.25, 5.3 и так дальше до 5.6

Обновите Perl :)
Записан

lexx

  • Пионер
  • *
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 4
    • Просмотр профиля
Re: не ставится Nconf
« Ответ #4 : Ноября 29, 2011, 10:40:13 pm »

5.12 младше 5.6 ????
это же не 5.1.2...

http://www.perl.org/
Current Perl version  - 5.14.2

Вообще ничего не понимаютогда )))
« Последнее редактирование: Ноября 29, 2011, 10:44:29 pm от lexx »
Записан

Sargas

  • Пионер
  • *
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 6
    • Просмотр профиля
Re: не ставится Nconf
« Ответ #5 : Ноября 30, 2011, 02:42:34 am »

Извините, видимо я что-то сам себе придумал )

Не стоит perl-DBD-MySQL.
cd /usr/ports/databases/p5-DBD-mysql51  только для своей версии MySQL'я ставьте 50,51,52 или 55.

Цитировать
NConf system requirements:


    * Apache webserver
    * PHP 5 or higher, php-mysql, php-ldap (only if using LDAP auth)
    * MySQL 5.0.2 or higher (with InnoDB)
    * Perl 5.6 or higher, perl-DBI, perl-DBD-MySQL
    * Nagios 3.x or Icinga 0.8x (binary necessary for testing generated config)


php.ini settings:


    * short_open_tag = On
    * register_globals = Off
    * magic_quotes_gpc = Off
Записан

lexx

  • Пионер
  • *
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 4
    • Просмотр профиля
Re: не ставится Nconf
« Ответ #6 : Ноября 30, 2011, 08:00:51 am »

Извините, видимо я что-то сам себе придумал )

Не стоит perl-DBD-MySQL.
cd /usr/ports/databases/p5-DBD-mysql51  только для своей версии MySQL'я ставьте 50,51,52 или 55.

Цитировать
NConf system requirements:


    * Apache webserver
    * PHP 5 or higher, php-mysql, php-ldap (only if using LDAP auth)
    * MySQL 5.0.2 or higher (with InnoDB)
    * Perl 5.6 or higher, perl-DBI, perl-DBD-MySQL
    * Nagios 3.x or Icinga 0.8x (binary necessary for testing generated config)


php.ini settings:


    * short_open_tag = On
    * register_globals = Off
    * magic_quotes_gpc = Off

А это зазве не оно???
# pkg_info | grep mysql
mysql-client-5.1.60 Multithreaded SQL database (client)
mysql-server-5.1.60 Multithreaded SQL database (server)
p5-DBD-mysql51-4.019 MySQL 5.1 driver for the Perl5 Database Interface (DBI)
php5-mysql-5.3.8    The mysql shared extension for php
« Последнее редактирование: Ноября 30, 2011, 08:02:58 am от lexx »
Записан

Sargas

  • Пионер
  • *
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 6
    • Просмотр профиля
Re: не ставится Nconf
« Ответ #7 : Ноября 30, 2011, 09:32:45 am »

Оно, но в 1 посте в выводе pkg_info его нет. В таком случае фиг его знает почему он не ставиться.
Записан

muff

  • Administrator
  • Долгожитель
  • ***
  • Karma: 0
  • Оффлайн Оффлайн
  • Сообщений: 283
    • Просмотр профиля
    • IT, Network, Beer!
Re: не ставится Nconf
« Ответ #8 : Декабря 14, 2011, 02:38:13 pm »

Сорри, как-то упустил тему...

Цитировать
5.12 младше 5.6 ?
это же не 5.1.2...

http://www.perl.org/
Current Perl version  - 5.14.2

Вообще ничего не понимаютогда )))
С Perl все в порядке. 5.12 "старше", чем 5.6.

Цитировать
Оно, но в 1 посте в выводе pkg_info его нет. В таком случае фиг его знает почему он не ставиться.
Потому что отсеивали по параметру "perl". Если хотите проверить, какие расширения perl установлены, воспользуйтесь командой pkg_info | grep p5-.

Цитировать
Не стоит perl-DBD-MySQL.
Установили?
Записан
Если нет ответа, то давайте подумаем...
 

Страница сгенерирована за 0.072 секунд. Запросов: 30.